Home Forums Plugins WooCommerce Sales Countdown Wrong time in countdown

Wrong time in countdown

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #156003

    ehdk
    Participant

      Hello support,

      We are experienced problems with your plugin.
      The problem are the use of sale end time.

      At first we experienced that the counter was 1 day behind.
      We then chose to update your plugin to see if it would solve our problem.

      Now it just does’nt add any days to the counter.
      I set it one month ahead, and yet it only counts the hours.

      This is the product: http://masterdeal.dk/produkt/smart-udstyr-til-cykelturen/

      Attachments includes screenshot of the matter.

      Attachments:
      You must be logged in to view attached files.
      #156286

      Thoa Kim
      Moderator

      Dear ehdk,

      Please give me wp-admin, using “access information“, we’ll check.

      Yours Sincerely,

      Thoa Kim

      ———-

      ThimPress Support Team

      #156886

      ehdk
      Participant

        I have now created an account to you at my website.
        The information can be found in “Access info”

        #157675

        Thoa Kim
        Moderator

        Dear ehdk,

        Because you disabled Schedule time start to time end http://prntscr.com/fbuvp6. I enabled this option and the date is displaying http://masterdeal.dk/produkt/smart-udstyr-til-cykelturen/

        I also installed the latest version of plugin for you.

        One more thing, the period of your support is expired. Please renew to receive our customer service.

        Yours Sincerely,

        Thoa Kim

        ———-

        ThimPress Support Team

        #158160

        ehdk
        Participant

          Thanks, Thoa Kim.
          You solved the problem with the countdown, but i have now encountered a new problem as the other was fixed.
          I have renewed my purchase in hope of you, solving the new problem.

          The problem now, is that it shows the regular price as sales price, but ONLY when no countdown is enabled (no schedule end or start).
          I have tested in TwentySeventeen theme, to rule out a bug in the theme i use.
          When i disable your plugin, the sales/regular price works yet again.

          #158198

          Thoa Kim
          Moderator

          Dear ehdk,

          Internal Server Error. Isn’t your site working?

          Yours Sincerely,

          Thoa Kim

          ———-

          ThimPress Support Team

          #158802

          ehdk
          Participant

            Hi Thoa Kim,

            We have experienced downtime these past days.
            The server should now be up and running again.
            Could i ask you to give it another go?

            #159425

            Thoa Kim
            Moderator

            Dear ehdk,

            We’re checking.

            Yours Sincerely,

            Thoa Kim

            ———-

            ThimPress Support Team

            #159792

            Thoa Kim
            Moderator

            Dear ehdk,

            The problem is resolved. Please check again and give me the feedback. Thank you.

            Yours Sincerely,

            Thoa Kim

            ———-

            ThimPress Support Team

            #159843

            ehdk
            Participant
              This reply has been marked as private.
              #160318

              Thoa Kim
              Moderator

              Dear ehdk,

              When you set start time & end time, WooCommerce will count sales daily. It means it counts by hours because the workflow of WooCommerce is to count daily. Just need to remove end time and count by day will display http://masterdeal.dk/produkt/laekkert-kuffertsaet-fra-sparco-3-stk/. In the next plugin version, we will add an option to allow sale by daily schedule.

              Yours Sincerely,

              Thoa Kim

              ———-

              ThimPress Support Team

              #183289

              ehdk
              Participant

                This is now a problem again.
                Same struggles as last time.
                The timer is off by -2 hours, and the regular price shows up as sale price.

                #183511

                Thoa Kim
                Moderator

                Dear ehdk,

                Can you please give me the link of product which has the problem?

                Yours Sincerely,

                Thoa Kim

                ———-

                ThimPress Support Team

                #183759

                ehdk
                Participant

                  This product is 2 hours off – AND it uses the sale price as regular price and vise versa.
                  The product is to be on sale from the 10th August – and it counts down alright, but the timer is off.
                  The time her i 14:00 – and it says 8 hours until sale-time = that means 22:00 o’clock which should be equal to 24:00 as the 10th starts there.
                  So my guess is that the plugin doesnt take account for the timezone differences in countries.
                  You fixed it last time – but we have updated WooCommerce (not your plugin as no update is avaiable).

                  You still have the same access as last time. We have not changed it.

                  #184039

                  Thoa Kim
                  Moderator

                  Dear ehdk,

                  We’ve created a test product to check but the time is working normally. Can you give me a product which timer is not working correctly for the reference?

                  Yours Sincerely,

                  Thoa Kim

                  ———-

                  ThimPress Support Team

                  #184112

                  ehdk
                  Participant

                    Hello again.

                    You can try see this product: http://masterdeal.dk/produkt/securitcam-fake-kamera-skraem-tyven-vaek/
                    When you set the sale date for today and let it stop tomorrow, it now shows 12 hours back for the counter. But it should really show 14 hours?

                    And I can see that it doesn’t show the “normal” price. It shows only the sale price and delete the “normal” price. You can see that on the same product.

                    Another issue:
                    When you set the sales date to be in the future, it shows the counter. It should not show the counter when you set a future sale date.
                    And when you set this future sale date, it shows the “normal” price twice. One with a slash over the price and one without.

                    You can try that on the same product as well.

                    And the time is still 2 hours short on both.

                    I have attached screenshots for both issues.

                    Attachments:
                    You must be logged in to view attached files.
                    #184146

                    Thoa Kim
                    Moderator

                    Dear ehdk,

                    We received your information. Our developers’re checking on it, please give us a little time, we’ll come back soon. Thank you for your patience.

                    Yours Sincerely,

                    Thoa Kim

                    ———-

                    ThimPress Support Team

                    #184689

                    Thoa Kim
                    Moderator

                    Dear ehdk,

                    We fixed. Please help me check again.

                    Yours Sincerely,

                    Thoa Kim

                    ———-

                    ThimPress Support Team

                    #184744

                    ehdk
                    Participant

                      Hello again.

                      Thanks for the reply.

                      But you have only fixed one of the issues. Again:

                      Issue #1:
                      When you set a future sale date, for example on this product: http://masterdeal.dk/produkt/securitcam-fake-kamera-skraem-tyven-vaek/
                      It shows the countdown. And it should not show the countdown.

                      Issue #2:
                      The timer shows the wrong time. It is set to UTC 0 but should use the UTC +2 (it should add 2 hours for the countdown). For example when there is 6 hours back on the sale, it should really be 8 hours, because of the timezone is not right. You can take a look on this product: http://masterdeal.dk/produkt/traadloes-alarm-med-bevaegelsessensor/

                      Please fix this soon. My customer is not happy about this taking so long. And it’s everytime we update the website this happens. Could you please just make an update for your plugin instead, so we don’t have to write to you every time?

                      Regards

                      Attachments:
                      You must be logged in to view attached files.
                      #185400

                      Thoa Kim
                      Moderator

                      Dear ehdk,

                      #1. When set the sale date in future, the countdonwn is displayed. That’s correct. Why shouldn’t it display?

                      #2. The problem is actually fixed. The timer show the correct time https://prnt.sc/g896zh. Maybe it’s due to cache so that you can’t see the changes. Please clear all cache and check again.

                      Yours Sincerely,

                      Thoa Kim

                      ———-

                      ThimPress Support Team

                      #185428

                      ehdk
                      Participant

                        Hello again.

                        #1. It should not be displayed, because nothing says that is a future sale? It doesn’t says anything else than if a product really is on sale. It should be different in some kind. Is it possible to remove?

                        #2. It is fixed. My bad!

                        #186023

                        Thoa Kim
                        Moderator

                        Dear ehdk,

                        When you set any future sale date, the plugin will display countdown as the default. You just can disable countdown for all products in WooCommerce >> Settings >> Sales Countdown tab.

                        Yours Sincerely,

                        Thoa Kim

                        ———-

                        ThimPress Support Team

                        #187370

                        Ingrid67
                        Participant
                          This reply has been marked as private.
                          #187560

                          Thoa Kim
                          Moderator

                          Dear ingrid67,

                          Please create your own topic if you have any problems.

                          Yours Sincerely,

                          Thoa Kim

                          ———-

                          ThimPress Support Team

                        Viewing 24 posts - 1 through 24 (of 24 total)

                        You must be logged in to reply to this topic. You can click here